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GEOPAK Bugs 
The following has been reported to BENTLEY/GEOPAK as software bugs. 

 
  - Items with the bug symbol have been confirmed by GEOPAK as bugs. 

  - Items with the green shaded bug symbol have been fixed but not necessarily released. 
 

# Posted Problem Area Description 
 

0808-
156 8-16-07 COGO Input File Utility 

This bug is unique to ProjectWise.  Cogo>Input File Utility>Delete.  
While working with files in ProjectWise, If you Delete an input file from 
Cogo>Input File Utility, the cogo window says "File #### is deleted" but the 
input file does not delete. In the Input File Utility dialog the input file disappears 
for a second and reappears.  When performing this task outside of 
ProjectWise, it deletes the file from the Input File Utility dialog and removes the 
actual file from the input file directory. 

0808-
155 8-8-07 D&C Mgr - Compute 

When computing graphic quantities using adHoc attributes, if the pay item 
description is attached as a Remark adHoc, the description does not come 
through in the computational results or Quantity Manager. 

0808-
154 7-25-07 adHoc Attribute Manager Changing adHocs with the adHoc Attribute Manager is removing some of the 

previously attached attributes. 

0808-
153 7-13-07 GEOPACK ProjectWise 

project folder 

Once the gpktools.rsc file exists in the ProjectWise project directory, a second 
user accessing the same DGN from that directory for checkout will also receive 
the gpktools.rsc file checked out as well. 

0808-
152 7-10-07 GEOPACK Drainage 

 When an outlet node is selected, the Library Items available include both the 
Outlet and Headwall library items. 
Follow-Up:  NOT A BUG – came back as WAD (works as designed) 

0808-
151 7-9-07 COGO Offset Profile When using the "Offset Profile" tool in Cogo (Element > Profile > Offset), 

MicroStation locks up.   

0808-
150 6-25-07 Project Manager Port Viewer 

When using the Port Viewer within Project Manager, if the Geopak preference 
for the station number of decimal places is set high enough (6) that the region 
does not fit in the Station text box, as soon as you click on the "Set" button and 
move the cursor over the XS View, the station text box switches to "1" instead 
of a valid station and the plan view goes off into an area way off of the chain. 

0808-
149 6-22-2007 Shape Maker Superelevation Shape Maker > Filler Lines > Method > By Station.  After a 

station value is entered, when you hit the Create. No filler line is created. 

0808-
148 5-24-2007 COGO Navigator 

When using the Navigator>Visualize> All Points tool it bogs down.   
The visualization status bar gets to 99% and then the Navigator begins  
to flicker.  After several minutes it will stop flickering and then be ok. 
Follow-Up:  This issue has been confirmed and logged. It is ticket number 
220858.  Not fixed in version 08.08.02.73 

0808-
147 5-25-2007 COGO Navigator 

Input file with parcel commands does not store the parcel correctly.  This 
particular parcel should have several Parent Tracts but only few get stored. 
Follow-Up:  Fixed in version 08.08.02.73 

0808-
146 5-14-07 Microstation 

The Graphical Cogo > Store Line from Existing Points command does not 
work when the MicroStation > Workspace > Preferences > Look and Feel > 
Default Tool is set to "None".  Click on the command, id the first point, and the 
tool disappears.  The MicroStation tool Settings says "No Active Tool". 
Follow-Up: Confirmed it is fixed in 08.08.02.73 

0808-
145 4-25-07 Survey SMD Feature 

Linear items place with Survey > Plans Preparation > Place SMD Feature 
are not being recognized by both the Survey > Plans Preparation > Place 
Legend tool and the ID tool in the Place SMD Feature tool. 
Follow-Up:  Confirmed it is fixed in 08.08.02.73 

0808-
144 3-19-07 Survey Editor 

Survey > Geometry > Points > Edit (Chains Edit too) (Also calling up the editor 
by double clicking in the cogo navigator) The crosshair doesn't disappear 
when you exit the editing tool.  Updating the view doesn't get rid of it either.  It 
only disappears after exiting Survey Manager. 
Follow-Up:  Confirmed it is fixed in 08.08.02.73 
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0808-
143 4-9-07 COGO Navigator 

While in COGO, the Navigator does not open with jobNS.gpk file.  Get a 
"System fault: 5  Cogonvgt unloaded"  error message.  However, the Navigator 
opens the same GPK file in our previous Geopak Version (08.05.01.56). 
Follow-Up:  Fixed in version 08.08.02.73 

0808-
142 4-9-07 COGO Command Editor 

The Cogo Command Editor does execute the Restore or Restore/Read 
command when the dgn file is in directory path that contains a space.   
Follow-Up:  Fixed in version 08.08.02.73 

0808-
141 3-27-07 Export DTM Conversion of tins to *.tn3 (topcon) Is very very slow. 

0808-
140 03-15-07 Geotech 

When opening an existing database in Geotech, a backup copy is created and 
the database is updated to version 3 but the alignment name is replaced with 
the original plus a lot of trailing spaces. The boreholes are now unavailable to 
the visualize dialogs or the convert between chains dialog. 
Work around: Copy the new database template (Soils Database Template 
V8.05.08.mdb) from S:\MndotV8Stds\DOT_GEOPAK\geotech\. Open in 
Microsoft Access and select "Import Other" and then "Old Soils Access 
Database". 

0808-
139 02-08-07 GEOPAK Proposed Cross-

section 

Processing GEOPAK Proposed Cross-section  
Cross-section File locks up when processing Cross-section. Does process 
correctly on GEOPAK Ver 08.05.01.56 and MS 08.05.05.55 
Work Around: In your dataset, there are "Shoulder in DGN Paved" (lvname 
= SHLD, color= 48) elements that are complex chains. If you drop those 
complex chains the dataset will process. 

0808-
138 02-07-07 GEOPAK Cross-section Blue 

Top Reports 

Not getting errors when there is Gaps in the Proposed Finish Grade Line. 
Note that tolerance is set to 0.1 
Also when in the search criteria dialog after your inial report the  
Lv names are no longer there, however when you select display 
the lv names select earlier highlight.  

0808-
137 02-07-07 GEOPAK Drainage Case 

Sensitive Node Names 

Users are able to create nodes with the same name as follows: 
1. Open Design file CaseSensNodes.dgn, Load drainage and  
   open CaseSensNodes.gdf project 
2. Open Navigator and go to nodes 
3. Open CB-1 and Apply 
4. Open Cb-1 and Apply 
5. Cell/label for CB-1 disappears and Cell/label for Cb-1 appears 

0808-
136 12-28-06 GEOPAK- Input File 

You get an error when you load and read an input file that has a data set 
name that has a space in it.  If you choose a data set name with a space in 
the survey project manager the information process fine.  This should be 
consistent. Work Around: Edit input file with textpad. 

0808-
135 

    
12-05-06 COGO Edit Point 

Attempting to remove the Elevation and Description values for 
stored points using the COGO Navigator > Edit Element (Store Point) 
dialog.  Even though you toggle off the Elevation and Description and 
then hit the Set Point, the Elevation and Description remain with the point. 
They do not get updated.  Redefine is toggled On. 

0808-
134 11-16-06 GEOPAK Drainage 

Unable to Save Prefix setting for Edit Drainage Profile Drainage Information 
Elevations 
1. Open Design file h275057_hyd.dgn, Load drainage and  
   open h275057_hyd.gdf project 
2. Select Component > Profile > Edit List  
3. Select Profile 5000-5008 
4. Select Grid & Labels > Elevations 
5. Toggle on Invert Elevations, Then place FL in for a prefix. Select apply, 
6. Then Select File save as JFMtest.ppf, then close out of Edit Profile. 
7. Then Select Component > Profile > Edit List and Select Profile 5007-5076 
8. Select File > Open JFMtest.ppf 
9. Select Select Grid & Labels > Elevations 
10. The Prefix FL was not saved under the prefix for Invert Elevations. 
Work Around: none  

0808-
133 

 
11-08-06 GEOPAK- Saving Chains 

The Chain is stored but the beginning station is 0+00 (Should be 125+00 as 
keyed in) Follow this sequence to replicate the problem: 
Applications>GEOPAK Road>Geometry>Layout Alignments Horizontal 
(HAG dialog) Tools>Alignment 
(Alignment dialog) Place PI Alignment 
Save Chain >Save Chain As... Chain: test 
- Begin Station: 125+00 
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Follow-Up: Sent .zip (.zzz) file to Steve Willoughby as requested. 

0808-
132 11-08-06 COGO Navigator - 

Change/Rename command 

COGO Navigator - Change/Rename command 
Can only change/rename in Navigator if Redefine is turned on.   
However if you use Key-in syntax it will redefine element even if Redefine is 
turned off. Work Around: no work around 

0808-
131 11-02-06 Survey Point Editor 

With a survey project open. Open the survey point editor. If you Modify or edit 
a Parameter, the description of the point disappears.  If you look in the 
navigator the description is also gone there. Work Around: no work around 

0808-
130 11-02-06 Survey Chain 

With a survey project open, when you double click on a survey chain in the 
navigator the survey chain editor is to come up with the chain in it that you 
double click on in the navigator. The problem is when you double click on a 
chain the survey chain editor comes up but does not have the chain in it that 
you selected in the navigator. You have to search for the correct chain. 
Work Around: no work around 

0808-
129 11-02-06 Trimble Link 

Trimble link does not support exporting more then one alignment.  There is a 
toggle to export all the alignments in the gpk file but it only exports the first 
alignment.  Also it doesn't handle equations, it just blows right by then.  
Trying to export from Geopak to a ACU this Version 11.21 with Active Sync.  
I reported this previously with a MN/DOT bug # of 2068.  
Work Around: No work around 

0808-
128 11-01-06 3PC: Place Influence 

Commands 

"Set place influence on/off" issued via 3pc commands are not working. 
This 3pc scans for items in a selection set, and if found draws a legend of 
these items which may be custom line styles.  The 3pc works fine if it is 
launched with place influence off. The problems show up when it is launched 
with place influence on. There were two related previously reported bugs in 
previous versions that were fixed.  (Mn/DOT bug 2036 - Geopak Tracking 
#DGRY-66LQUV and Mn/DOT bug 2042 - Geopak Tracking #dgry-683md2) 
Work Around: No work around 

0808-
127 11-01-06 D&C Mgr Compute – Export 

to QM 

 
Quantities computed (D&C Mgr) with a Fence do not show up when Exported 
to the QM .mdb file.The Phase and items are created but no quantities show 
up. Work Around: It works fine using Active Design File, View and Boundary 
Element. Follow Up: Sum called 11-01-06 and said he would look at it.  

0808-
126 10-27-06 GEOTECH Borehole 

Navigator 

The file does not open. 371 Soils Database9_17_03x.mdb.  Get a "Cannot 
open ACCESS database" Information message. 
Work Around: No work around. 

00808-
124 10-20-06 Add Parcel  

When running input file with ADD Parcel commands the parcel is not stored  
correctly or completly.  
When using the attached input file (par1add.i) I get the following problems: 
1- The ADD parcel is not visualized. 
2- One of the TAKE areas (NRW2B) is not stored at all.  
3- The feature (ERWENC) was not stored with Taking ERWENCB 
Work Around: No work around. 

0808-
123 10-19-06 Merging GPK file 

When Merging GPK file, the parcel Owner does not come through.  
Work around: No work around. 

0808-
122 

 
10-13-06 GEOPAK Drainage Warning 

Message 

Missing or Invalid Longitudinal Slope Warning when using Analyze: 
 You get a warning message "Missing or Invalid Longitudinal Slope"  
Work Around:  none 

0808-
121 10-13-06 GEOPAK Drainage: 

Lock/unlock Link Elevations 

When Lock/unlock Elevations under Network Configuration it locks both 
inverts and the slope.   
Work Around: Need to unselect (hold) the slopes for link each network 
you lock or unlock. This is a very dangerous tool since it locks or  
unlocks all the link elevation in a network. Use with caution and make backup 
before using.  

0808-
120 

 
10-13-06 GEOPAK Drainage Negative 

Slopes 

Analyzing a network when holding the slope and upstream invert elevation 
you get a negative slope. Work Around: Hold the Links upstream invert 
elevation and downstream invert elevation not the slope. Follow-up: JM 
confirmed it is a bug. 

0808-
118 

 
10-05-06 GEOPAK Drainage: Drainage 

Profile 

The Feature in Edit Drainage Profile > Display > Drainage Crossing doesn't 
work. It did work in GEOPAK Version 08.05.01.56. 
Work Around: None. Follow up: JM confirmed it is a bug 
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0808-
117 

 
10-02-06 GEOPAK Drainage: Link 

Graphics 

The links will change attachment when the node bottom is edited for 
subsequent nodes without closing the node dialog. 
Work Around: Use the update links icon in the link toolbox or 
the update links in the navigator. Follow-up: JM confirmed it is a bug. 
 

2070 
 

04-21-06 Import Pay items from CSV 
Document 

When importing pay items and quantities from a CSV doc, the quantities do 
not come through.  
Follow up: none. 

2069 04-20-06 
Design and Computation 

Manager - Stationing 
Operations for a chain 

This bug has been sent before as MN/DOT BUG # 884. Using D&C Mgr. to 
plot PC, PT & CS labels as a Stationing Operation for a chain. The PT label 
does not plot when there is a Station Equation at the PT, and when this PT is 
at the end of a chain. We prefer to see both/all labels at this location   
Follow up:   9/2/03 TB- Bug not resolved in 8.1  

2068 04-03-06 Trimble link from GEOPAK 

Have been testing Trimble link export from GEOPAK and discovered that it 
does not support exporting more than one alignment. There is a toggle to 
export all the alignments in the gpk file but it only exports the first alignment. 
Also it doesn’t handle equations; it just blows right by them. Follow up:   

2067 03-23-06 Design & Computation 
Manager- setting units 

When setting the compute parameters for a Design & Computation Manager 
item, if the configuration variable 
GPK_COMPUTATION_ENGLISH_UNIT_DEF_FILE is set to point to the file 
ComputationUnitDefinitonEnglish.csv in any directory other than the bin 
directory, an “Invalid Unit Definition” error occurs when you select any units 
(Computation Method: Standard Unit) from the “Units” dialog and click OK on 
the “Parameters for Target Item” dialog. Computing works fine, it is setting 
the units that generate the error. Work Around: Set both the English and 
metric configuration variable to the same English csv file)  

2066 
 

03-14-06 Export Alignments and 
Profiles 

Using Cogo to export alignments and profiles using the Trimble DC option.  
The DC files make multiple files to handle the equations but in the files the 
file name stays the same as the original alignment. (Example: The file name 
is AE22NB1 but inside the file the name is AE22NB.) Also it would be good to 
have the ability to make a DC file with more than one alignment in it.   
Follow-up: none 

2065 
 

02-23-06 Export Alignments and 
Profiles 

Using Cogo to export alignments and profiles using the GEODIMETER P39 
option, the problem is that Geopak adds 20 units onto the front and end of 
the alignment and it does not add it to the same azimuth as the alignment. 
Export files have been attached directly from GEOPAK (.rln files) and the 
MnDot edited files (.are files). Mndot mostly uses 2D alignments for the 
GEODIMETER P29 (.are files). Also in the second export file for the 
alignment AE22NB, ae22nb.rln is missing the information at the top of the 
file. Follow up: none 

 
2062 

 

 
11-21-05 

 
D&C Manager – Shape Mode 

The Design & Computation Manager Shape Mode will not create a shape 
when an element making up a side is a shape.  Neither automatic nor semi-
auto mode works.  Work Around: Drop the shape. 

 
2061 

 

 
11-07-05 

 
Build DTM Tool 

When using Build GEOPAK DTM tool to create .DAT and .TIN files, the .DAT 
file is not generated as expected. The .DAT file is not representative of what 
is being called for in the Set Search/More Detail dialog. Follow up: none 

 
2060 

 
 
 

10-26-05 

 
 

Existing Cross-Sections 

When collecting conventional Cross-Sections using Milepoint stationing at a 
increment of .01 of a mile sometimes 2 Cross-sections occur on one Cross-
section cell. Follow-up: none 

 
 
 

2058 

 
 

10-20-05 

 
 

GEOPAK DTM Tool 
 

DTM > Analysis > Profile - When placing/selecting an element to create a 
profile though a void the Show Extracted Points and Export to ascii file don't 
match. The Show Extracted Points shows the points on both sides of the 
void.  The Export to ascii file only gives points on one side of the void.  
Workaround: Follow up: 

 
2057 

 
09-12-05 

 
Geotech - Apply Zero Drape 

Area 

The "Apply Zero Drape Area" is checked when I create my boundary for the 
LS tin that I want, but when the tin is created, it comes up with bad 
elevations. Work Around: Follow up: none 
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2050 

 
 
 

05-06-05 

 
 
 

Draw XS Tool 

When rerunning Ground Cross Sections using Pattern "By DGN File", 
changes made to the pattern file (pattern lines are lengthened or shortened) 
are not reflected in the Cross Sections as you would expect. Even if you 
delete the Cross Section elements (ground lines and XS cell), the changes  
made to the pattern lines are not reflected in the new cross sections unless 
you do a Shutdown and Restart of your computer before you draw the 
ground sections again. Follow-up: none 

 
 
 

2049 

 
 
 
 

04-28-05 

 
 
 
 

Plan Preparation 

In plans preparation It does not seem to be using the Plot Scale from the 
Applications>User Preferences> Feature Preferences on custom line styles. 
It works fine for placing cells from the SMD but not linear items. If you 
change the plot scale in the Element>Line Style>custom dialog, it plots linear 
items as you would expect, but if you close and reopen the SMD or pick a 
different item, the plot scale reverts back to 1. It still says 100, 200 or 
whatever you have set it to, in the dialog, if you leave it open but when you 
draw a linear element it is being placed at 1 scale. If you close the 
Element.>Line Style>custom dialog it uncheck the scale and a 1 is ghosted 
out. Follow-up: none 

 
 

2048 
 

 

 
 

04-20-05 

 
 
 

XS Reports 

DTM Prop 3D not generating properly, not picking up all proposed elements, 
incorrect elevations.  
Work Around: Problem occurs with sections that are not in the proper 
(default) order in the file.  If sections are in columns by stationing bottom to 
top, left to right all works fine.  If not, problems may occur. 

 
 

2047 
 

04-12-05  
 
 

Draw Ancillary Features 

Multiple cells are being placed at the same cross section. Sometimes it 
places multiple cells (extra) right on top of each other and sometimes it 
places extra cells) on the same cross section but at different offsets or 
elevations. 
Work Around: Works ok when using the ".tin" file rather than "by feature" 
and "by level symbology" 

2046 
 

 
03-29-05 

QM QM reporting incorrect station values for items. 
Work Around: Recompute and store to a new .MDB 

 
 

2043 
 

 
01-20-05 

 
 

Survey field processing 

This occurs when processing field file fixed.fld an error occurs.  
Work Around:  When breaking the file down to individual setup (files 
test1b.txt to text8b.txt) and processing them together in one data set they run 
fine, no error.  

 
 

2038 
 

 
 
10-14-04 

 
Plans Preparations tool > 

Place SMD 
Feature 

When using the Plans Preparations tool,  Place SMD 
Feature the Plot Scale setting in Feature Preference does not work for the 
custom line styles under the Place Linear Influence.  It ignores the setting 
and places it at 100 scale.  The Plot scale does however work for Place Point 
symbol. Work Around: Set the MicroStation custom line style scale to 
desired scale.  

 
 
 

2029 
 

 
 
 
 

09-29-04 

 
 
 

Cross Section and 
Plan/Profile Sheet 

Composition 

Within the GEOPAK Create Digital InterPlot Set Setting Dialog, the Printer 
Name is ignoring the value that is defined in the Setting File Template Name 
(settings file).  When a Printer Name is manually defined in this dialog, it 
doesn't hold the printer/queue in the .IPS file that gets generated. Essentially, 
setting the printer name in either the .SET file or the dialog has no effect on 
the printer setting in the IPS file that is created.  Work Around:  To set the 
desired printer, within Iplot Organizer use the File> Print Setup pull down tool 
to set the printer queue. 

2026 

 
 

09-28-04 
Geotech The elevation from the tin isn’t being stored in the access database. Bug has 

been changed to Enhancement Request. Follow up: Not fixed in MR. 

 
 
 

2024 

 

 
 
 
 

09-23-04 

 
 
 
 

Utilowner.3PC 

When running the 3PC application to assign ownership (adhocs) to utilities in 
a dgn file, it works fine the first time, but if you try to do it again (in the same 
session), it gives you a strange message, "Cross Section is not authorized 
for use" and will not work. Work Around:  A line has been added to the 
Util_Owner_Local.3pc and Util_Owner_Dist.3pc files to work around the 
problem.  
Follow-up:  Not fixed in MR. 

 
 

2023 
 

 
 
 
 

09-23-04 

 
 
 
 

Utility Computing/ 
Tabulating 

Utility elements mapped from the SMD (cell items) take on the symbology 
from the SMD, except the cell header is a color of 0.  When computing from 
the D&C Manager, the items supplemental search criteria has to include the 
color 0 (not just the color of the graphic elements) or they don't get 
computed. Work Around:  Utilities.ddb has been adjusted to search for 
colors 0-253 and weights 0-15. Follow-up:  Resubmitted bug. 
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2018 

 

 
09-08-04 

COGO > Element > Profile > 
Offset 

 

Using the dialog to store an offset profile creates a profile with extra vpi's. 
The vpi's are getting added at the vpc's of some (but not all) of the vertical 
curves. Work Around: Use key in command store profile from…  
Follow-up:  Not fixed in MR 

 
 
 
 
 
 


